Skio Merchant Dashboard is inaccessible.

Incident Report for Skio

Resolved

This issue is resolved and all of Skio is fully operational again.
Posted Feb 19, 2025 - 19:30 EST

Update

We are continuing to monitor for any further issues.
Posted Feb 19, 2025 - 19:15 EST

Monitoring

Our team has implemented a fix for this behavior and Skio is working as expected now. We'll continue to monitor the fix.
Posted Feb 19, 2025 - 19:13 EST

Investigating

Our team is currently investigating an issue that is preventing Skio's merchant dashboard, and customer portal from loading.
Posted Feb 19, 2025 - 19:06 EST
This incident affected: Skio Customer Portal and Skio Merchant Portal.