Analytics dashboards not loading for some stores

Incident Report for Skio

Resolved

The incident with Google Cloud Platform has been resolved.
Posted Jun 12, 2025 - 16:16 EDT

Identified

Google Cloud Platform is experiencing service disruptions and affecting analytics dashboards, causing them to fail to load for some stores. We're monitoring updates from Google and will provide updates here when possible.
Posted Jun 12, 2025 - 14:30 EDT
This incident affected: Skio Merchant Portal.