Merchant and Customer Portals are recovered. We are continuing to investigate fall out from this outage including delayed order processing, subscription updates and Journeys and running backfills where necessary.
Posted Aug 05, 2025 - 16:50 EDT
Monitoring
A fix has been implemented and we are seeing improved speed for merchant and customer portal loads. Charge processing is also recovering. We will continue to monitor the improvements until fully resolved.
Posted Aug 05, 2025 - 14:16 EDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 05, 2025 - 13:13 EDT
Identified
We are continuing to investigate this issue as it's been identified to be ongoing.
Posted Aug 05, 2025 - 11:54 EDT
Update
We've identified and fixed the cause of the slowness on merchant and customer dashboards. Thank you for your patience while we resolved this issue.
Posted Aug 05, 2025 - 11:37 EDT
Investigating
We are currently investigating an issue causing extreme slowness for some merchants and customers logging into their Skio accounts. This is also affecting subscription processing today. We'll keep you updated on the progress of our investigation and hope to get this resolved quickly!
Posted Aug 05, 2025 - 11:22 EDT
This incident affected: Skio Charge Processing, Skio Customer Portal, and Skio Merchant Portal.