Errors loading customer data in the dashboard

Incident Report for Skio

Resolved

This is resolved. Merchants briefly saw "Unable to load customers" when opening the Customers page in their dashboard. We deployed a fix and have confirmed customer data is loading normally.

Subscriptions, billing, and customer-facing pages were not affected at any point.
Posted Sep 21, 2026 - 13:33 EDT

Monitoring

We've identified a likely cause of the intermittent errors loading customer data and deployed a fix. Merchants should no longer see the "Unable to load customers" message. We're monitoring to confirm the issue is fully resolved.
Posted Sep 21, 2026 - 12:51 EDT

Investigating

We're investigating reports of some merchants are seeing "Unable to load customers" when opening the Customers page in their dashboard. Subscriptions, billing, and customer-facing pages are not affected.
Posted Sep 21, 2026 - 11:05 EDT
This incident affected: Skio Merchant Portal.