Problems accessing Skio Dashboard and Customer Portal

Incident Report for Skio

Resolved

Our engineering team isolated the issue and this incident has been resolved.
Posted Mar 22, 2023 - 15:00 EDT

Update

We are continuing to investigate this issue.
Posted Mar 22, 2023 - 14:51 EDT

Investigating

Merchants and customers may experience problems while attempting to access the merchant dashboard and customer portal. Our team is currently investigating.
Posted Mar 22, 2023 - 14:50 EDT
This incident affected: Skio Customer Portal and Skio Merchant Portal.