Skio Dashboard and Customer Portal loading slowly for some users

Incident Report for Skio

Resolved

The incident has been resolved
Posted Jun 03, 2025 - 14:58 EDT

Monitoring

We've implemented a fix and are monitoring the results.
Posted Jun 03, 2025 - 13:45 EDT

Identified

We have identified the root of the issue and are working towards a resolution.
Posted Jun 03, 2025 - 13:36 EDT

Investigating

We're currently investigating an issue that is causing the Skio Dashboard and Customer Portal to load slowly or time out for some users.
Posted Jun 03, 2025 - 13:23 EDT
This incident affected: Skio Customer Portal, Skio Merchant Portal, and Skio API.