This issue is fully resolved and all created subscriptions are in Skio.
Posted Mar 08, 2025 - 14:18 EST
Monitoring
A fix has been implemented and the Skio merchant dashboard is back up and running. New subscription orders which went through checkout are processed correctly but will be delayed to show up in Skio.
Posted Mar 08, 2025 - 09:09 EST
Update
We are continuing to investigate this issue.
Posted Mar 08, 2025 - 08:37 EST
Investigating
We are currently investigating an issue which prevents the Skio dashboard from resolving, and results in a spinning loading wheel.
Posted Mar 08, 2025 - 08:34 EST
This incident affected: Skio Customer Portal and Skio Merchant Portal.